GIS AH IND M6

Modul: Membuat Data Vektor

Membuat peta dengan data yang sudah ada hanyalah permulaan saja. Pada modul ini, anda akan mempelajari bagaimana memodifikasi data vektor yang sudah tersedia dan membuat set data yang sama sekali baru.

Pelajaran: Membuat Set Data Vektor Baru

Data yang anda gunakan harus diperoleh dari suatu tempat. Untuk aplikasi yang paling umum, data mungkin sudah tersedia; namun, untuk aplikasi khusus atau proyek yang bersifat spesifik, kemungkinan besar tidak ada data yang tersedia. Dalam kasus ini, anda harus membuat data sendiri.

Tujuan dari pelajaran ini: Membuat set data vektor baru.

image Ikuti bersama: Kotak Dialog Pembuatan Layer

Sebelum dapat menambahkan data vektor baru, anda membutuhkan set data vektor untuk menampungnya. Dalam kasus ini, anda akan mulai dengan membuat data yang sama sekali baru ketimbang menyunting set data yang sudah ada. Oleh karena itu, pertama-tama anda perlu mendefinisikan set data yang baru.

Anda perlu membuka kotak dialog New Vector Layer untuk membuat layer baru.

  • Cari dan klik menu Layer \rightarrow New \rightarrow New Shapefile Layer.

Anda akan melihat kotak dialog berikut ini:

image

Pada tahap ini anda perlu menentukan jenis set data apa yang ingin dibuat. Masing-masing jenis layer vektor dibangun secara berbeda di latar belakang sehingga anda tidak dapat mengubah jenisnya setelah layer tersebut dibuat.

Untuk latihan berikutnya, kita akan membuat fitur-fitur baru yang mendeskripsikan daerah. Untuk fitur semacam ini, anda perlu membuat sebuah set data polygon.

  • Klik tombol Polygon:

image

Ini tidak akan berpengaruh terhadap sisa pilihan dalam kotak dialog tersebut, tetapi akan memastikan penggunaan jenis geometri yang tepat pada saat pembuatan set data vektor.

Kolom berikutnya memungkinkan anda untuk menentukan Sistem Referensi Koordinat (CRS). Sebuah CRS menentukan bagaimana mendeskripsikan suatu titik di permukaan Bumi dalam hal koordinat. Karena terdapat banyak cara untuk melakukan hal ini, maka terdapat berbagai jenis CRS yang berbeda. CRS yang digunakan dalam proyek ini adalah WGS84, sehingga pengaturannya sudah benar:

image

Berikutnya, terdapat sekumpulan kolom yang dikelompokkan dalam New attribute. Secara default, layer baru hanya memiliki atribut pada kolom id (yang dapat anda lihat pada Attributes list) di bawah ini. Akan tetapi, agar data yang anda buat menjadi berguna, anda perlu mendeskripsikan fitur-fitur yang akan anda buat pada layer baru ini. Untuk tujuan ini, kita cukup menambahkan satu kolom yang diberi nama name.

  • Replikasi pengaturan berikut ini, kemudian klik tombol Add to attributes list:

image

  • Periksa apakah kotak dialog anda terlihat seperti ini:

image

  • Klik OK. Kotak dialog penyimpanan akan muncul.
  • Buka direktori exercise_data.
  • Simpan layer baru anda sebagai university_property.shp.

Layer baru akan muncul pada Layers list.

image Ikuti bersama: Sumber data

Pada saat membuat data baru, data tersebut harus menyangkut objek yang benar-benar ada di permukaan bumi. Oleh karena itu, anda perlu mendapatkan informasi mengenai objek tersebut dari suatu tempat.

Ada banyak cara untuk memperoleh data mengenai suatu objek. Misalnya, anda dapat menggunakan GPS untuk merekam koordinat titik-titik di permukaan bumi untuk diimpor ke dalam QGIS. Atau anda dapat melakukan survei dengan teodolit dan memasukkan koordinat secara manual untuk membuat fitur baru. Anda juga dapat menggunakan proses digitasi untuk menelusuri objek melalui data penginderaan jarak jauh, misalnya pencitraan satelit atau fotografi udara.

Pada contoh ini, anda akan menggunakan pendekatan digitasi. Sampel set data raster telah disediakan, jadi anda hanya perlu mengimpor mereka seperlunya.

  • Klik tombol Add Raster Layer:

image

  • Buka exercise_data/raster/.
  • Pilih file ITB_raster.tif.
  • Klik Open. Sebuah gambar akan dimuat ke dalam peta anda.
  • Cari gambar baru tersebut pada Layers list.

image

Anda akan mendigitasi tiga kolom berikut ini:

image

  • Sembunyikan semua layer kecuali layer raster dan university_property.

Untuk memulai digitasi, anda harus masuk ke modus penyuntingan. Perangkat lunak GIS umumnya mengharuskan langkah ini untuk mencegah kesalahan dalam penyuntingan atau penghapusan data penting. Modus penyuntingan diaktifkan atau dimatikan secara individual pada masing-masing layer.

Untuk masuk ke modus penyuntingan pada layer school_property:

  • Klik kanan pada layer di dalam Layer list untuk memilihnya. (Pastikan anda telah memilih layer yang benar agar anda tidak menyunting layer yang salah.)
  • Klik tombol Toggle Editing.

image

Jika anda tidak dapat menemukan tombol ini, periksa apakah toolbar Digitizing sudah aktif. Seharusnya terdapat tanda centang di sebelah menu View \rightarrow Toolbars \rightarrow Digitizing.

Setelah memasuki modus penyuntingan, anda akan melihat bahwa alat bantu digitasi telah aktif:

image

Keterangan gambar dari kiri ke kanan:

  • Toggle Edit: Mengaktifkan/menonaktifkan modus penyuntingan.
  • Save Edits: Menyimpan perubahan pada layer.
  • Add Feature: Memulai digitasi sebuah fitur baru.
  • Move Feature(s): Memindahkan keseluruhan fitur.
  • Node Tool: Memindahkan satu bagian dari sebuah fitur.
  • Delete Selected: Menghapus fitur yang di pilih (hanya aktif jika ada fitur yang dipilih).
  • Cut Features: Memotong fitur yang dipilih (hanya aktif jika ada fitur yang dipilih).
  • Copy Features: Menyalin fitur yang dipilih (hanya aktif jika ada fitur yang dipilih).
  • Paste Features: Menyisipkan kembali fitur yang dipotong atau disalin ke dalam peta (hanya aktif jika ada fitur yang telah dipotong atau disalin).

Anda ingin menambah fitur baru.

  • Klik tombol Add Feature untuk segera memulai digitasi!

Anda akan melihat bahwa kursor tetikus anda telah berubah menjadi tanda benang silang. Ini memungkinkan anda untuk menempatkan titik yang ingin didigitasi dengan lebih akurat. Ingatlah ketika menggunakan alat bantu digitasi, anda dapat memperbesar dan memperkecil tampilan peta dengan menggulirkan roda tetikus; anda juga dapat melihat seluruh bagian peta dengan menahan roda tetikus dan menggesernya.

Fitur pertama yang akan anda digitasi adalah lapangan tenis:

image

  • Mulai digitasi dengan mengklik sebuah titik di sepanjang tepi lapangan.
  • Tempatkan lebih banyak titik dengan mengklik di sepanjang tepinya hingga bentuk yang anda buat sepenuhnya melingkupi lapangan tersebut.
  • Untuk menempatkan titik terakhir, klik kanan di manapun anda inginkan. Ini akan melengkapi fitur dan membuka kotak dialog Attributes.
  • Masukkan nilai – nilai berikut ini:

image

  • Klik OK dan anda telah membuat fitur baru!

Ingatlah jika anda membuat kesalahan ketika mendigitasi fitur, anda selalu dapat menyuntingnya kembali setelah selesai. Jika anda membuat kesalahan, lanjutkan digitasi sampai anda selesai membuat fitur seperti di atas. Kemudian:

  • Pilih fitur dengan alat bantu Select Single Feature:

image

Anda dapat menggunakan:

  • Alat bantu Move Feature(s) untuk memindahkan seluruh fitur,
  • Node Tool untuk memindahkan satu titik yang mungkin salah anda tempatkan,
  • Delete Selected untuk menghapus seluruh fitur sehingga anda dapat mencoba lagi, dan
  • Item menu Edit \rightarrow Undo atau ctrl + z untuk membatalkan langkah terakhir anda.

image Coba sendiri:

  • Digitasi lapangan atletik dan kolam renang. Gunakan gambar ini untuk membantu anda:

image

Ingat bahwa setiap fitur baru harus memiliki nilai id yang unik.

Catatan: Setelah selesai menambahkan fitur pada sebuah layer, jangan lupa untuk menyimpan hasilnya dan keluar dari modus penyuntingan.

Kesimpulan

Pelajaran ini telah menunjukkan kepada anda bagaimana membuat fitur baru pada sebuah set data. Pelatihan ini tidak mencakup penambahan fitur titik yang tidak begitu diperlukan karena anda telah belajar bekerja dengan fitur-fitur yang lebih rumit (garis dan poligon). Penambahan fitur titik dilakukan dengan cara yang sama, tetapi anda hanya perlu mengklik sekali pada tempat yang diinginkan; kemudian berikan atribut seperti biasa untuk menyelesaikan pembuatan fitur.

Mengetahui cara melakukan digitasi adalah hal yang penting karena merupakan kegiatan yang sangat umum dalam program SIG (Sistem Informasi Geografis).

Apa Selanjutnya?

Setelah diperkenalkan dengan pembuatan data vektor, anda dapat mempelajari cara menganalisis data tersebut untuk memecahkan masalah. Ini merupakan topik dari modul selanjutnya.

Click here to go to Modul 7: Analisis Vector