
BAB 9

Modul: Melengkapi Analisis

Anda sekarang telah mengetahui dua bagian dari analisis: bagian vektor dan raster . Dalam

modul ini, Anda akan melihat bagaimana menggabungkan kedua format tersebut. Anda akan

menyimpulkan analisis dan menyajikan hasil akhirnya.

9.1 Pelajaran: Konversi Raster ke Vektor

Konversi dari format raster ke vektor memungkinkan Anda untuk menggunakan data raster dan

data vektor dalam memecahkan masalah di GIS, serta menggunakan metode analisis tertentu

pada data geografis dalam kedua format data tersebut. Hal ini dapat membuat Anda lebih

fleksibel dalam mempertimbangkan sumber data mana dan metode pengolahan apa yang akan

digunakan untuk memecahkan masalah GIS.

Untuk mengkombinasikan analisis raster dan vektor, Anda harus mengkonversi satu tipe data

ke tipe data yang lain. Mari kita mengubah hasil raster dari pelajaran sebelumnya ke data

vektor.

Tujuan untuk latihan ini: untuk mendapatkan hasil raster ke vektor yang dapat digunakan

untuk menyelesaikan analisis.

9.1.1 Ikuti Bersama Tool Raster to Vector

• Klik pada Raster → Conversion → Polygonize (Raster ke Vektor). Kotak dialog akan

muncul.

• Lakukan pengaturan seperti dibawah ini:
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• Ubah nama field (yang menggambarkan nila-nilai dari raster) menjadi suitable.

• Simpan shapefile di folder exercise_data/residential_development as

all_terrain.shp.

Sekarang Anda memiliki file vektor yang berisi semua nilai file raster. Anda hanya tertarik

dengan area yang sesuai, yaitu, poligon-poligon yang memiliki nilai suitable bernilai 1.

9.1.2 Coba sendiri...

Lihat kembali modul analisis vektor .

• Buat file vektor baru yang hanya berisi poligon yang nilai suitable adalah 1.

• Simpan file baru di folder exercise_data/residential_development as su-

itable_terrain.shp.

Periksa hasil Anda

9.1.3 Ikuti Bersama: Tool Vector to Raster

Walaupun tidak penting untuk masalah kita sekarang, ini berguna untuk mengetahui konversi

sebaliknya dari yang sudah ditampilkan di atas.

• Klik pada Raster → Conversion → Rasterize (Vector to Raster) untuk memulai tool ini,

kemudian atur seperti gambar di bawah:
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• Input file adalah all_terrain;

• Output file... adalah :kbd:‘ exercise_data/residential_development/raster_conversion.tif‘;

• Width dan Height masing-masing adalah 837 and 661.

Catatan: Ukuran file data raster hasil vektorisasi dibuat sama dengan data raster asli yang
telah di vektorisasi. Untuk melihat dimensi dari suatu gambar, dapat dilihat di metadata file

tersebut (Tab Metadata di Layer Properties).

• Klik OK pada kotak dialog untuk memulai proses konversi.

• Untuk mengecek keberhasilan proses ini, bandingkan raster baru dengan yang raster yang

asli. Nilai pixel antara file yang baru dan yang lama harus sama persis.

9.1.4 Kesimpulan

Konversi antara format raster dan vektor memungkinkan Anda memperluas kegunaan data, dan

tidak perlu menyebabkan degradasi data.

9.1.5 Apa selanjutnya?

Saat ini kita memiliki hasil analisis terrain dalam format vektor, hasil tersebut dapat digunakan

untuk memecahkan masalah pertanian yang harus kita pertimbangkan dalam pengembangan

perumahan.
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9.2 Pelajaran: Menggabungkan Analisis

Data hasil vektorisasi dari analisis raster akan memungkinkan Anda untuk memilih lahan per-

tanian yang memiliki terrain yang cocok.

Tujuan untuk pelajaran ini: Menggunakan terrain hasil vektorisasi untuk memilih lahan per-

tanian yang cocok.

9.2.1 Coba sendiri...

• Simpan peta Anda saat ini (raster_analysis.qgs).

• Buka peta yang telah Anda analisis vektor sebelumnya (analysis.qgs).

• Dalam Layers list, terdapat beberapa layer : - hillshade, - solution, - important_roads

dan salah satu dari aerial_photos atau DEM.

• Disamping layer yang sudah ada di peta hasil pekerjaan Anda sebelumnya, tambahkan

juga setdata suitable_terrain.shp.

• Pilih semua pertanian ( dalam layer solution) yang bersinggungan dengan layer

suitable_terrain (Gunakan metode select by location seperti yang dipakai sebe-

lumnya.)

• Simpan sebagai new_solution.shp.

Anda sekarang memiliki layer pertanian untuk solusi Anda:
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9.2.2 Cobalah sendiri... Periksa hasilnya

Teliti setiap lahan pertanian di layer new_solution Anda. Bandingkan layer-layer tersebut de-

ngan layer suitable_terrain dan ubah simbologi untuk layer new_solution sehingga layer ter-

sebut hanya memiliki garis luarnya saja. Apa yang Anda dapatkan dari beberapa pertanian

tersebut? Apakah mereka semua sesuai hanya karena mereka bersinggungan dengan layer sui-

table_terrain? Mengapa sesuai dan mengapa tidak? Mana yang tidak sesuai menurut anda?

Periksa hasil Anda

9.2.3 Cobalah sendiri... Memperbaiki Hasilnya

Sekarang Anda dapat melihat dari hasil, bahwa beberapa lahan pertanian yang bersinggungan

tidak terlalu sesuai. Masih ada kemungkinan untuk memperbaiki analisisnya.

Kita bisa melihat bahwa ada beberapa pertanian yang memiliki area yang sesuai, akan tetapi

area ini terlalu kecil untuk digunakan. Oleh karena itu, keputusan yang dibuat dalam memilih

pertanian yaitu pertanian tersebut harus memiliki lahan yang sesuai dengan area sepanjang 350

meter atau lebih. Bagaimana Anda memastikan bahwa pertanian tersebut memenuhi persyarat-

an ini? Untuk menjawab pertanyaan ini, gunakan (a) tool vector analysis.
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Periksa hasil Anda

9.2.4 Kesimpulan

Anda sekarang telah dapat menjawab pertanyaan awal mengenai mencari lahan yang sesuai

untuk pengembangan kawasan permukiman. Rekomendasi Anda mengenai pengembangan

properti didukung dengan berbagai alasan menggunakan hasil analisis.

9.2.5 Apa selanjutnya?

Di bagian selanjutnya Anda akan menyajikan hasil ini sebagai bagian dari tugas kedua anda.

9.3 Latihan

Map Composer digunakan untuk membuat peta baru yang merepresentasikan hasil dari analisis

Anda. Masukkan layer-layer berikut:

• places (with labels),

• hillshade,

• solution (atau new_solution),

• important_roads dan

• baik aerial_photos atau: guilabel:DEM.

Tuliskan dan sertakan penjelasan singkat pada peta yang telah dibuat . Sertakan dalam pen-

jelasan tersebut kriteria yang digunakan dalam memilih lahanpertanian yang akan digunakan

untuk pengembangan properti. Jelaskan rekomendasi Anda tentang lahan pertanian terpilih.

9.4 Pelajaran: Latihan Tambahan

Dalam pelajaran ini, Anda akan dipandu untuk melakukan analisis GIS lengkap pada QGIS.

Catatan: Pelajaran ini dikembangkan oleh Linfiniti and S Motala (Universitas Teknologi Cape
Peninsula)

9.4.1 Permasalahan

Anda bertugas untuk mencari area yang berada di dalam dan di sekitar Semenanjung Penin-

sula dimana area tersebut cocok untuk habitat tumbuhan langka jenis fynbos. Luas area yang

Anda cari berada di Semenanjung Cape yaitu sebelah selatan Melkbosstrand dan sebelah ba-

rat Strand.Para Ahli Botani telah memberikan kriteria area yang sesuai untuk spesies tanaman

tersebut:

248 Bab 9. Modul: Melengkapi Analisis



Quantum GIS Training Manual, Rilis 1.0

• Tumbuh pada lereng yang menghadap ke Timur.

• Tumbuh pada lereng dengan kemiringan 15% dan 60%.

• Tumbuh di daerah yang memiliki curah hujan tahunan sebesar > 1200 mm.

• Hanya dapat ditemukan setidaknya 250 m dari pemukiman penduduk.

• Luas vegetasi yang ada harus minimal 6000m2 dalam suatu area.

Sebagai relawan dari Cape Nature, Anda telah setuju untuk mencari sepetak tanah yang berada

di dekat rumah Anda. Gunakan keahlian GIS Anda untuk menentukan sepetak tanah mana

yang akan Anda pilih.

9.4.2 Solusi yang diambil

Untuk mengatasi masalah ini, Anda harus menggunakan data yang tersedia (tersedia dalam

exercise_data/more_analysis) untuk menemukan area kandidat yang paling dekat

dengan rumah Anda. Jika Anda tidak tinggal di Cape Town (yang merupakan dasar permasa-

lahan ini) Anda dapat memilih rumah lain di kawasan Cape Town. Solusi ini akan melibatkan:

• Analisis DEM untuk menemukan kelerengan yang menghadap ke timur dan lereng yang

memiliki kemiringan yang benar;

• Analisis data raster curah hujan untuk menemukan area mana yang memiliki jumlah

curah hujan yang benar;

• Analisis zonasi layer vektor untuk menemukan area mana yang berada jauh dari pemu-

kiman dan memiliki ukuran yang benar.

9.4.3 Menyiapkan Peta

• Klik tombol “CRS status” yang berada di paling bawah sudut kanan layar.Dibawah tab

CRS pada layar yang muncul, Anda akan melihat kotak dialog Coordinate reference sys-

tems of the world.

• Pada kotak dialog ini, arahkan ke Projected Coordinate Systems → Universal Transverse

Mercator (UTM).

• Pilih WGS 84 / UTM zone 33S (dengan kode EPSG 32733).

• klik OK. Sekarang peta ini berada pada sistem koordinat referensi UTM33S.

• simpan peta dengan mengklik pada tombol toolbar Save Project As atau gunakan File →

Save Project As... pada item menu.

• Simpan peta pada direktori dengan nama Rasterprac yang perlu Anda buat di kom-

puter Anda. Anda akan menyimpan layer apapun yang Anda buat pada direktori ini juga.
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9.4.4 Memuat data ke dalam Peta

Untuk mengolah data, Anda akan perlu memuat beberapa layer (street, names, zones, rainfall,

DEM) ke dalam bidang peta.

Untuk data vektor ...

• Klik pada tombol :guilabel:’Add Vector Layer, atau gunakan Layer → Add Vector La-

yer... pada menu item.

• Pada dialog yang muncul, pastikan bahwa tombol radio :guilabel:‘File‘dipilih.

• Klik pada tombol Browse.

• Pada dialog yang muncul buka direktori exercise_data/more_analysis/streets

• Pilih file Street_Names_UTM33S.shp.

• Klik Open.

Dialog akan menutup dan menampilkan dialog awal dengan alamat file yang ditunjukkan pada

text field di samping tombol Browse. Hal ini memungkinkan Anda untuk memastikan bahwa

file yang dipilih adalah benar . Hal ini juga memungkinkan untuk memasukkan alamat file pada

field secara manual, jika Anda ingin melakukannya.

• Klik Open. Layer vektor akan memuat di peta Anda. Warnanya sudah ditetapkan secara

otomatis. Kita akan mengubah warna ini nanti.

• Ubah nama layer menjadi Streets.

• Klik kanan pada Layers list ( secara defaultnya, panel yang berada di sisi kanan layar).

• Klik Rename pada dialog yang muncul dan ubah namanya,apabila sudah selesai, Tekan

kunci Enter.

• Ulangi proses penambahan vektor, akan tetapi untuk kali ini, pilih file Generali-

sed_Zoning_Dissolve_UTM33S.shp yang terdapat dalam direktori Zoning.

• Ubah menjad Zoning.

Untuk data raster...

• Klik pada tombol Add Raster Layer, atau gunakan Layer → Add Raster Layer... pada

item menu.

• Arahkan pada file yang sesuai, pilih dan klik click Open.

• Lakukan hal ini pada dua file raster , yaitu:DEM/reproject/DEM dan Rainfa-

ll/reprojected/rainfall.tif.

• Ubah nama raster curah hujan ke Rainfall (dengan huruf awalnya kapital). Awalnya

ketika dimuatnya, citra akan nampak menjadi abu-abu .Jangan khawatir, warna ini nanti

akan diubah.

• Simpan peta.
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Untuk melihat dengan jelas apa yang terjadi, Simbologi untuk layer harus diganti.

9.4.5 Ubah simbologi pada layer vektor

• Dalam Layers list, klik kanan di atas layer Streets.

• Pilih Properties dari menu yang muncul.

• Beralih pada tab:guilabel:Style dalam kotak dialog yang muncul.

• Klik pada tombol berlabel Change, dengan kotak yang menunjukkan warna layer Streets

saat ini.

• Pilih warna baru pada kotak dialog yang muncul.

• Klik OK.

• Klik OK lagi dalam kotak dialog :Layer Properties . hal ini akan merubah warna di layer

Streets.

• Ikuti dengan proses yang sama untuk layer Zoning dan pilih warna yang sesuai untuk

layer tersebut.

9.4.6 Mengubah simbologi pada layer raster

Simbologi pada layer raster agak berbeda.

• Buka kotak dialog Properties untuk raster Rainfall.

• Beralih ke tab: guilabel: Style. Anda akan melihat bahwa model dialog ini sangat berbeda

dari versi yang digunakan untuk layer vektor.

• Pastikan tombol Use standard deviation dipilih.

• Ubah nilai dalam kotak yang terkait ke 2,00 (secara default, nilai tersebut seharusnya

0.00 ).

• Di bawah judul Contrast enhancement, Ubah nilai Current pada daftar dropdown ke

Stretch to MinMax.

• Klik OK. Raster “Rainfall” apabila terlihat akan berubah warna, sehingga memungkinkan

Anda untuk melihat nilai kecerahan dari masing-masing pixel.

• Ulangi proses ini untuk DEM, tetapi atur standar deviasi yang akan digunakan dengan

kerengangan sampai 4.00.

9.4.7 Mengubah urutan layer

• Dalam Layers list, klik dan seret layar ke atas dan ke bawah untuk mengubah urutan layer

yang muncul di peta.

• Versi baru dari QGIS mungkin memiliki kotak centang Control rendering order dibawah

Layers list. Pastikan kotak tersebut dicentang.
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Sekarang setelah semua data sudah dimuat dan terlihat secara jelas, analisis dapat dimulai.Akan

lebih baik apabila operasi pemotongan dilakukan lebih dahulu. Hal ini dilakukan agar daya

yang digunakan untuk processing tidak terbuang percuma untuk menghitung nilai pada area

yang tidak kita gunakan.

9.4.8 Mencari kabupaten yang benar

• Muat layer vektor admin_boundaries/Western_Cape_UTM33S.shp ke dalam

peta Anda.

• Ubah namanya menjadi Districts.

• klik kanan pada layer Districts dalam Layers list.

• Pada menu yang muncul, pilih item menu Query....Maka kotak dialog Query Builder

muncul.

Anda sekarang akan membuat sebuah query untuk menyeleksi kabupaten yang ada pada daftar

berikut:

• Bellville,

• Cape,

• Goodwood,

• Kuils River,

• Mitchells Plain,

• Simons Town, dan

• Wynberg.

• Pada daftar Fields, Klik dua kali pada field NAME_2. Ini akan menampilkan teks SQL

where clause seperti di bawah ini.

• klik tombol =;sebuah tanda = akan ditambahkan pada query SQL.

• Klik tombol All di bawah daftar Values (yang sekarang kosong). Setelah menunggu

sebentar, daftar Values ini akan terisi dengan nilai-nilai yang ada pada field yang dipilih

(NAME_2).

• Klik dua kali nilai Bellville dalam daftar Values. Sama seperti sebelumnya, nilai ini akan

ditambahkan ke query SQL.

Untuk memilih lebih dari satu kabupaten, Anda akan membutuhkan operasi boolean OR.

• Klik pada tombol OR dan tombol ini akan muncul pada query SQL.

• Dengan menggunakan prose yang sama seperti yang telah dilakukan di atas, tambahkan

baris berikut pada query SQL yang ada:

"NAME_2" = ’Cape’

• tambahkan operasi lain OR, kemudian bekerjalah dengan daftar kabupaten di atas dengan

menggunakan cara yang sama.
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• query akhir seharusnya

"NAME_2" = ’Bellville’ OR "NAME_2" = ’Cape’ OR "NAME_2" = ’Goodwood’ OR

"NAME_2" = ’Kuils River’ OR "NAME_2" = ’Mitchells Plain’ OR "NAME_2" =

’Simons Town’ OR "NAME_2" = ’Wynberg’

• Klik OK. Kabupaten yang muncul di peta Anda sekarang dibatasi dengan daftar yang

anda buat di atas.

9.4.9 Pemotongan Raster

sekarang Anda mempunyai cakupan area penelitian. Anda dapat memotong raster untuk area

ini.

• Pastikan hanya layer berikut yang terlihat DEM, Rainfall dan Districts.

• Districts harus berada di atas agar dapat terlihat.

• buka kotak dialog dengan memilih item menu Raster → Extraction → Clipper.

• Dalam daftar dropdown Input file (raster), pilih layer DEM.

• Spesifikasikan lokasi keluaran pada text field dengan mengklik tombol Select....

• Arahkan direktori Anda ke Rasterprac.

• Masukkan nama file.

• Simpan file. Tinggalkan kotak centang the No data value dengan keadaan tidak aktif.

• Gunakan modus pemotongan Extent dengan memastikan bahwa tombol yang benar dipi-

lih.

• Klik dan seret area ke dalam bingkai, sehingga daerah yang meliputi kabupaten dipilih.

• Centang Load into canvas when finished.

• Klik OK.

• Setelah operasi pemotongan selesai, JANGAN TUTUP kotak dialog Clipper ini (Apabila

Anda melakukannya, Anda akan kehilangan area clipping yang sudah anda definisikan)

• Pilih raster Rainfall dalam daftar dropdown Input file (raster) dan pilih nama file keluaran

yang berbeda.

• jangan mengubah ke pilihan lain. Jangan mengubah daerah kliping yang sudah Anda

buat gambar sebelumnya. Tinggalkan segala sesuatunya dalam keadaan sama dan klik

OK.

• Sesudah operasi pemotongan kedua lengkap, Anda dapat menutup kotak dialog Clipper.

• Simpan peta.

9.4.10 Bersihkan peta

• Hilangkan layer Rainfall dan DEM dari Layers list:
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• Klik kanan pada layer-layer ini dan pilih Remove.

– Hal ini tidak akan menghapus data dari perangkat penyimpanan Anda, tetapi hanya

akan membawanya keluar dari peta Anda.

• Nonaktifkan label pada layer Streets:

– Klik tombol Labeling.

– Hapus tanda centang pada kotak Label this layer with.

– Klik OK.

• Tampilkan lagi semua layer Streets:

– klik kanan pada layer yang ada dalam Layers list.

– Pilih Query.

• Pada kotak dialog Query yang muncul, klik tombol Clear, kemudian klik OK.

• Tunggu sementara data dimuat. semua jalan sekarang akan terlihat.

• Ubah simbologi raster seperti yang dilakukan sebelumnya (Lihat mengubah simbologi

pada layer raster).

• Simpan peta.

• Anda sekarang dapat menyembunyikan layer vektor dengan menghilangkan tanda cen-

tang pada kotak yang berada di sebelah layer tersebut dalam Layers list.Dengan demikian

pembuatan peta lebih cepat dan menghemat waktu.

Untuk membuat hillshade, Anda akan perlu menggunakan sebuah plugin yang telah ditulis

untuk tujuan ini.

9.4.11 Mengaktifkan plugin Raster Terrain Analysis

Plugin ini disertakan secara default dalam QGIS 1.8. Akan tetapi, plugin ini mungkin tidak

langsung terlihat .Untuk melihat apakah plugin ini dapat diakses pada sistem Anda:

• Klik pada item menu Plugins –> Manage Plugins....

• Pastikan kotak yang berada di sebelah Raster Terrain Analysis plugin dipilih.

• Klik OK.

Anda sekarang akan mempunyai akses ke plugin ini melalui item menu Raster → Terrain

analysis.

Ingat bahwa plugin kadang-kadang mungkin tergantung pada modul Python tertentu yang di-

instal pada sistem Anda. Jika sebuah plugin tidak dapat digunakan karena adanya komponen

yang dibutuhkan tidak dapat ditemukan, silakan minta bantuan tutor atau pengajar Anda.

9.4.12 Buat Hillshade

• Dalam Layers list, pastikan layer DEM aktif (dengan kata lain, tersorot pada saat diklik).
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• Klik pada item menu Raster → Terrain analysis → Hillshade untuk membuka kotak

dialog Hillshade.

• Tentukan lokasi yang tepat untuk layer keluaran dan namakan hillshade.

• Periksa kotak dialog Add result to project.

• Klik OK.

• Tunggu sampai proses ini selesai.

Layer baru dengan nama hillshade telah muncul di Layers list Anda.

• Klik kanan pada layer hillshade yang ada dalam Layers list dan munculkan pada kotak

dialog Properties.

• Klik pada tab Transparency dan atur slider transparancy ke 80%.

• Klik OK pada kotak dialog.

• Perhatikan efek ketika hillshade transparan ditumpangkan di atas potongan DEM.

9.4.13 Kelerengan

• Klik pada item menu Raster → Terrain analysis.

• Pilih tipe analisis Slope, dengan potongan DEM sebagai layer masukan.

• Spesifikasikan nama file yang sesuai dan lokasi untuk keperluan hasil.

• Periksa kotak dialog Add result to project.

• Klik OK.

Citra kelerengan akan dihitung dan ditambahkan ke dalam peta. Namun, seperti biasa citra

tersebut ditampilkan dengan warna abu-abu. Untuk melihat secara jelas apa yang terjadi, ubah

simbologinya sebagai berikut.

• Buka kotak dialog layer Properties (seperti biasa, dengan mengklik kanan menu pada

layer).

• Klik pada tab Style.

• Dimana tertulis Grayscale (Dalam menu dropdown Color map), ubah ke :Pseudocolor.

• Pastikan bahwa tombol Use standard deviation dipilih.

9.4.14 Aspek

• Gunakan pendekatan yang sama seperti menghitung kelerengan, tapi pilih Aspek di kotak

dialog awal.

Ingatlah untuk menyimpan peta secara periodik.
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9.4.15 Mengklasifikasikan ulang raster

• Klik pada item menu Raster → Raster calculator.

• Spesifikasikan direktori Rasterprac Anda sebagai lokasi untuk layer keluaran.

• Pastikan kotak dialog Add result to project dipilih.

Dalam daftar Raster band di sebelah kiri, Anda akan melihat semua layer raster dalam daftar

Layers list. Jika Layer Lereng Anda disebut slope, maka akan terdaftar sebagai slope@1.

Kelerengan harus berada pada 15 and 60 derajat. Semua yang berada kurang dari 15 or lebih

dari 60 harus dikesampingkan.

• Menggunakan daftar item dan tomol dalam antamuka, Buatlah ekspresi sebagai berikut:

((slope@1 < 15) OR (slope@1 > 60)) = 0

• Atur field Output layer pada lokasi dan nama file yang sesuai.

• Klik OK.

Sekarang carilah aspek yang benar (menghadap ke timur dengan 45 and 135 degrees) dan

gunakan pendekatan yang sama seperti sebelumnya.

• Buatlah ekspresi berikut:

((aspect@1 < 45) OR (aspect@1 > 135)) = 0

• Cari curah hujan yang benar dengan menggunakan cara yang sama (lebih dari 1200mm).

Buat ekspresi sebagai berikut:

(rainfall@1 < 1200) = 0

Setelah mengklasifikasikan semua raster , Anda sekarang akan melihat semua raster tersebut

sebagai persegi berwarna abu-abu dalam peta Anda (dengan asumsi peta tersebut telah ditam-

bahkan dengan benar). Untuk menampilkan secara jelas data raster yang hanya dua kelas (1

and 0,yang berarti benar atau salah),Anda harus mengubah simbologinya.

9.4.16 Mengatur style untuk layer reklasifikasi

• Buka tab Style dalam kotak dialog Properties seperti biasanya.

• Di bawah judul Load min / max values from band, pilih tombol radio Actual (slower).

• Klik pada tombol Load.

field Custom min / max values seharusnya sekarang sudah terisi dengan nilai 0 and 1. (Apabila

tidak, ada kesalahan pada reklasifikasi data Anda dan Anda butuh untuk mengulang kembali

bagian tersebut)

• di bawah judul Contrast enhancement, atur daftar dropdown Current ke Stretch To Mi-

nMax.

• Klik OK.
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• lakukan untuk tiga raster reklasifikasi, dan ingat untuk menyimpan peta Anda!

Satu-satunya kriteria yang tersisa adalah bahwa daerah tersebut harus jauh dari daerah perkota-

an dengan jarak 250m. Kami akan memenuhi persyaratan ini dengan memastikan bahwa dae-

rah yang kita hitung adalah 250m atau lebih dari tepi area pedesaan. Oleh karena itu,pertama-

tama, kita perlu menemukan semua daerah pedesaan.

9.4.17 Menemukan daerah pedesaan

• Sembunyikan layer-layer yang ada dalam Layers list.

• tampilkan layer vektor Zoning.

• Klik kanan pada layer vektor Zoning.dan pilihlah kotak Query.

• Buat query berikut:

"Gen_Zoning" = ’Rural’

Lihat petunjuk awal untuk membuat query Streets jika Anda mengalami kesulitan.

• Apabila Anda sudah selesai, tutup kotak dialog Query.

Anda akan melihat kumpulan poligon dari layer Zonasi. Anda perlu menyimpan ploigon-

poligon baru ini ke file layer yang baru.

• Klik kanan pada menu Zoning, pilih Save as....

• Simpan layer Anda dalam direktori Zoning.

• Beri nama file keluaran dengan rural.shp.

• Klik OK.

• Tambahkan layer ke peta Anda.

• Klik pada item menu Vector → Geoprocessing Tools → Dissolve.

• Pilih layer rural sebagai layer vektor masukan Anda.Centang kotak :guilabel::Use only

selected features, pada saat Anda meninggalkan dialog tersebut.

• Di bawah Dissolve field, pilih — Dissolve all —.

• Simpan layer Anda dalam direktori Zoning.

• Klik OK. Sebuah kotak dialog akan muncul dan menanyakan apakah Anda ingin menam-

bahkan layer baru pada TOC (“Table of Contents”, mengacu ke Layers list).

• Klik Yes.

• Tutup dialog Dissolve.

• Hilangkan layer rural and Zoning.

• Simpan peta.
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Sekarang Anda perlu mengecualikan daerah-daerah yang berada dalam batas : kbd: 250m dari

tepi daerah pedesaan. Lakukan ini dengan menciptakan buffer negatif, seperti yang dijelaskan

di bawah ini.

9.4.18 membuat buffer negatif

• Klik item menu Vector → Geoprocessing Tools → Buffer(s).

• Dalam kotak dialog yang muncul, pilih layer rural_dissolve sebagai layer vektor masuk-

an Anda (Use only selected features tidak boleh dicentang).

• Pilih tombol Buffer distance dan ketikkan nilai -250 dalam field yang terkait; Nilai yang

negatif berarti bahwa buffer tersebut pasti merupakan buffer internal.

• Periksa kotak dialog Dissolve buffer results.

• Atur file keluaran ke direktori yang sama seperti file vektor rural yang lainnya.

• Beri nama file keluaran dengan nama rural_buffer.shp.

• Klik Save.

• Klik OK dan tunggu sampai proses selesai.

• Pilih Yes pada kotak dialog yang muncul.

• Tutup kotak dialog Buffer.

• Hilangkan layer rural_dissolve.

• Simpan peta.

Untuk menggabungkan zona pedesaan dalam analisis yang sama dengan tiga raster yang ada,

diperlukan rasterisasi juga. Agar raster tersebut sesuai dengan analisis,raster tersebut harus

diubah ke ukuran yang sama. Oleh karena itu, sebelum Anda melakukan rasterisasi, Anda

harus mengklip layer vektor pada daerah yang sama dengan tiga raster. Sebuah vektor hanya

dapat dipotong oleh vektor lain, jadi pertama-tama Anda harus membuat poligon berbentuk

kotak dengan ukuran yang sama dengan raster.

9.4.19 Membuat vektor bounding box

• Klik pada item menu Layer –> New –> New Shapefile Layer....

• Di bawah judul Type, pilih tombol Polygon.

• Klik Specify CRS dan atur sistem referensi koordinat dengan WGS 84 / UTM zone

33S : EPSG:32733.

• Klik OK.

• Klik OK juga pada kotak dialog New Vector Layer.

• Simpan vektor pada direktori Zoning.

• Beri nama file keluaran sebagai bbox.shp.
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• Sembunyikan semua layer kecuali layer baru bbox dan satu raster yang sudah diklasifi-

kasikan ulang.

• Pastikan bahwa layer bbox disorot dalam Layers list.

• Arahkan pada item menu View > Toolbars dan pastikan bahwa Digitizing dipilih. Kemu-

dian Anda akan melihat ikon toolbar dengan sebuah gambar pensil atau koki di atasnya.

Ini adalah tombol Toggle editing.

• Klik tombol Toggle editing untuk masuk ke edit mode. Ini memungkinkan Anda untuk

mengedit sebuah layer vektor.

• Klik tombol Add feature, yang biasanya berada dekat dengan tombol Toggle editing.

Tombol ini mungkin tersembunyi di balik tombol panah ganda, jika demikian, klik dua

kali tanda panah ganda untuk menampilkan tombol Digitizing yang tersembunyi pada

toolbar.

• Dengan tombol Add feature aktif, klik kanan pada sudut raster. Anda mungkin perlu

memperbesar tampilan peta menggunakan tombol skrol pada mouse supaya lebih akurat.

Untuk melakukan pergeseran di atas peta dalam mode ini, klik dan seret di atas peta

menggunakan tombol tengah atau roda mouse.

• Untuk poin keempat dan poin akhir, klik kanan untuk menyelesaikan bentuknya.

• Masukkan nomor acak sebagai ID.

• Klik OK.

• Klik pada tombol Save edits.

• Klik tombol Toggle editing untuk menghentikan sesi editing.

• Simpan peta.

Sekarang Anda memiliki sebuah kotak pembatas yang dapat digunakan untuk memotong layer

buffer rural.

9.4.20 memotong layer vektor

• Pastikan bahwa hanya layer bbox dan rural_buffer terlihat di atasnya.

• Klik pada item menu Vector > Geoprocessing Tools > Clip.

• Pada kotak dialog yang muncul , atur layer vektor masukan ke layer rural_bufferr dan

potong layer ke bbox, dengan kedua kotak Use only selected features tidak dicentang.

• Letakkan file keluaran di bawah direktori Zoning.

• Beri nama file keluaran dengan rural_clipped.

• Klik OK.

• Ketika diminta untuk menambahkan layer untuk TOC, klik: guilabel:Yes.

• Tutup kotak dialog.

• Bandingkan tiga layer dan lihat hasil Anda sendiri.
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• Hilangkan layer bbox and rural_buffer, kemudian simpan peta Anda.

Sekarang :kbd:‘rural_clipped‘Anda siap untuk dirasterisasi.

9.4.21 Rasterisasi layer vektor

Anda harus menentukan ukuran piksel untuk raster baru yang Anda buat, sehingga langkah

pertama Anda harus mencari ukuran piksel dari salah satu raster yang tersedia.

• Buka kotak dialog Properti dari salah satu tiga raster yang ada.

• Alihkan ke Tab Metadata.

• Buat catatan nilai X dan Y di bawah judul Dimensions dalam tabel Metadata.

• Tutup kotak dialog Properties.

• klik pada menu item Raster → Conversion → Rasterize. Anda mungkin akan menerima

tentang dataset Anda yang tidak mendukung. Anda dapat mengabaikan peringatan ini.

• Pilih rural_clipped sebagai layer masukkan Anda.

• Atur lokasi file keluaran dalam direktori Zoning.

• Beri nama file keluaran dengan rural_raster.tif.

• Periksa kotak New size dan masukkan nilai X dan Y yang sebelumnya sudah Anda buat

di catatan.

• Centang kotak Load into canvas.

• Klik ikon pensil di sebelah kolom teks yang menunjukkan perintah yang akan dijalank-

an. Pada akhir teks yang ada, tambahkan spasi dan kemudian tambahkan -burn 1.Hal

Ini memberitahukan fungsi Rasterisasi untuk “burn” vektor yang ada ke dalam raster

yang baru dan memberikan wilayah dengan cakupan nilai vektor baru dari 1 (berlawanan

dengan gambar yang lain, yang secara otomatis akan menjadi 0).

• Klik OK.

• Raster baru akan muncul dalam peta Anda setelah proses operasi selesai.

• Raster baru akan terlihat seperti persegi panjang abu-abu - Anda dapat mengubah tam-

pilan seperti yang Anda lakukan untuk raster reklasifikasi.

• Simpan peta Anda.

Sekarang Anda sudah memiliki masing-masing empat kriteria untuk raster yang terpisah, Anda

perlu mengkombinasikan semuanya untuk mencari area mana yang sesuai.Untuk melakukan-

nya, raster akan dikalikan satu sama lain. Ketika ini terjadi, semua piksel yang tumpang tindih

dengan nilai 1 akan tetap mempertahankan nilai 1, tetapi jika sebuah pixel memiliki nilai 0 pa-

da salah satu dari empat raster tersebut, maka hasilnya tetap akan 0 . Dengan cara ini, hasilnya

akan berisi daerah yang tumpang tindih.
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9.4.22 menggabungkan raster

• Klik pada item menu Raster → Raster calculator.

• Buat ekspresi berikut (dengan nama yang sesuai dengan nama layer-layer Anda, tergan-

tung bagaimana Anda menyebutnya):

[Rural raster] * [Reclassified aspect] * [Reclassified slope] *
[Reclassified rainfall]

• Atur lokasi keluaran ke direktori Rasterprac.

• beri nama raster keluaran dengan nama cross_product.tif.

• Pastikan bahwa dialog Add result to project dicentang.

• Klik OK.

• Ubah simbologi pada raster yang baru dengan cara yang sama seperti yang Anda atur

pada layer raster lainnya.Raster baru Anda sekarang menampilkan area dimana semua

kriteria sudah dipenuhi.

Untuk mendapatkan hasil akhir, Anda perlu memilih daerah yang lebih besar dari 6000m^2.

Namun, menghitung daerah-daerah secara akurat hanya mungkin dapat dilakukan pada layer

vektor, sehingga Anda akan perlu melakukan raster vektorisasi.

9.4.23 Vektorisasi raster

• Klik pada item menu Raster → Conversion → Polygonize.

• Pilih raster cross_product.

• Atur lokasi keluaran ke Rasterprac.

• Beri nama file dengan nama candidate_areas.shp.

• Pastikan mencentang Load into canvas when finished.

• Klik OK.

• Tutup dialog apabila prosesing selesai.

Semua area raster telah divektorisasi, jadi Anda hanya perlu menyeleksi area-area yang mem-

punyai nilai 1.

• Buka dialog Query untuk vektor baru.

• Buat query ini:

"DN" = 1

• Klik OK.

• Buat file vektor baru dari hasil kemudian simpan vektor dengan nama candidate_areas

setelah proses selesai (dan hanya area-area yang memiliki nilai 1 yang nampak). Gunak-

an fungsi Save as... pada klik kanan layer menu ini.
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• Simpan file dalam direktori Rasterprac.

• Namakan file dengan nama candidate_areas_only.shp.

• Simpan peta Anda.

9.4.24 Hitung area untuk masing-masing poligon

• Buka layer vektor baru dengan mengklik kanan pada menu.

• Pilih Open attribute table.

• Klik pada tombol Toggle editing mode yang terletak di bagian bawah tabel, atau tekan

Ctrl+E.

• Klik pada tombol Open Field Calculator yang berada di bagian bawah tabel, atau tekan

Ctrl+I.

• Di bawah judul New field pada kotak dialog yang muncul, masukkan nama field area.

Field keluaran harus bertipe integer, dan panjang field harus 10.

• Dalam tipe Field calculator expresion:

$area

Hal ini berarti bahwa field calculator akan menghitung aluas masing-masing poligon

dalam layer vektor dan kemudian mengisi kolom baru yang bersifat integer (dengan nama

area) dengan data hasil perhitungan.

• Klik OK.

• Lakukan hal yang sama untuk field baru bernama id. Dengan tipe Field calculator exp-

resion:

$id

This ensures that each polygon has a unique ID for identification purposes.

• Klik lagi pada Toggle editing mode dan simpan kembali editan Anda apabila Anda di-

minta melakukannya.

9.4.25 Memilih area dengan ukuran tertentu

Setelah areanya diketahui:

• Buat query seperti biasa untuk memilih poligon yang lebih besar dari

6000m^2.Querynya sebagai berikut:

"area" > 6000

• Simpan area yang terseleksi sebagai layer vektor baru dengan nama solution.shp.

Anda sekarang memiliki area untuk solusi Anda, dimana Anda dapat memilih salah satu yang

terdekat dengan rumah Anda.
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9.4.26 Digitasi rumah Anda

• Buatlah layer vektor baru seperti yang Anda lakukan sebelumnya, kali ini, pilih Type

dengan format for:guilabel:Point.

• Pastikan layer tersebut berada dalam CRS yang benar!

• Beri nama layer baru tersebut sebagai house.shp.

• Selesai membuat layer baru.

• Masuk ke dalam mode edit (dengan layer baru pada posisi dipilih).

• Klik lokasi rumah Anda atau tempat permukiman berada, gunakan jalan sebagai pandu-

an. Anda mungkin harus membuka layer lain untuk membantu Anda menemukan rumah

Anda. Jika Anda tidak tingal di daerah sekitarnya, cukup klik tempat yang berada di

antara jalan-jalan tersebut dimana rumah tersebut bisa dibayangkan.

• Masukkan nomor acak sebagai ID.

• Klik OK.

• Simpan editan Anda dan keluar dari mode edit.

• Simpan peta.

Anda akan perlu menemukan cetroid (“centers of mass”) untuk area poligon yang digunakan

untuk membantu Anda memutuskan daerah mana yang paling dekat dengan rumah Anda.

9.4.27 Hitung centriod poligon

• Klik pada menu item Vector → Geometry Tools → Polygon centroids.

• Beri nama file keluaran sebagai solution.shp.

• layer keluaran disimpan dalam direktori Rasterprac.

• Panggil file tujuan yaitu solution_centroids.shp.

• Klik OK dan tambahkan hasilnya ke TOC (Layers list), kemudian tutup kotak dialog.

• Posisikan layer baru ke atas layer-layer lain, sehingga Anda dapat melihatnya.

9.4.28 Hitung centoid yang berada paling dekat dengan rumah An-

da

• Klik pada item menu Vector –> Analysis Tools –> Distance matrix.

• Layer masukkan seharusnya adalah rumah Anda dan layer target adalah solu-

tion_centroids. Kedua layer tesebut harus menggunakan filed :kbd:‘id‘sebagai ID unik

mereka.

• Matrik keluaran harus bertipe linear.

• Atur lokasi dan nama keluaran yang sesuai.
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• Klik OK.

• Buka file dalam teks editor (misalnya Notepad atau impor ke spreadsheet). Perhatikan

target ID dikaitkan dengan Distance terpendek . Mungkin ada lebih dari satu ID yang

berada pada jarak yang sama.

• buat qery dalam QGIS untuk memilih area yang hanya berada paling dekat dengan rumah

Anda (Untuk memilihnya gunakan field id).

Ini adalah jawaban akhir untuk pertanyaan dari penelitian ini.

Masukkan layer hiilshade semi-transparan di Atas raster pilihan Anda (seperti DEM atau raster

:guilabel:‘slope‘sebagai contohnya). Juga masukkan poligon terdekat untuk solusi Anda serta

masukkan rumah Anda. Ikuti semua praktek terbaik untuk kartografi dalam membuat peta

Anda.
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