BAB 10

Modul: Plugin

Plugin memungkinkan Anda untuk memperbanyak fungsi dalam QGIS . Dalam modul ini,
Anda akan ditunjukkan bagaimana mengaktifkan dan menggunakan plugin.

10.1 Pelajaran: Menginstal dan mengatur Plugin

Untuk mulai menggunakan plugin, Anda perlu tahu cara mengunduh, menginstal dan meng-
aktifkannya. Untuk dapat melakukan ini, Anda akan belajar bagaimana menggunakan Plugin
Installer dan Plugin Manager.

Tujuan dari pelajaran ini : Untuk dapat mengerti dan menggunakan sistem Plugin QGIS.

£
10.1.1 9 Ikuti Bersama: Mengatur Plugin

* Untuk membuka Plugin Manager, klik pada item menu Plugins Plugins — Manage Plu-
gins.

» Pada kotak dialog yang muncul, cari plugin GdalTools:
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QGIS Plugin Manager .

Filter [ |

To enable / disable a plugin, click its checkbox or description
4. DxF2shp Converter
0 % Converts from dxF to shp file format

GPS Tools :]
M Tools for loading and importing GPS data ]

GdalTools (Version 1.2.29)
& I Integrate gdal tools into qgis

Georeferencer GDAL

(] — Georeferencingrasters using GDAL
Heatmap
] Creates a Heatmap raster for the input point vector

Interpolation plugin
— dkJ

A mliain Far inkarmalabioan bhaeod sanousckicoe aF sossebor Laese

Plugin Directory: /home/rudi/apps/qagis-1_8/lib/qgis/plugins

| selectAll | | clearall || cancel |[ oK |

» Klik pada kotak dialog di sebelah pluginnya dan non-aktifkan.
» Klik OK.

* Sekarang amati di bawah menu Raster. Anda akan melihat bahwa fungsi-fungsi yang
Anda gunakan sebelumnya telah menghilang. Hal ini dikarenakan, fungsi-fungsi tersebut
merupakan bagian dari plugin GdalTools,yang perlu diaktifkan sebelum digunakan.

* Buka kembali Plugin Manager dan aktifkan kembali plugin GdalTools dengan mencen-
tang kotak disebelahnya.

¢ Jika Anda membuka kembali menu Raster, Anda akan melihat tool ini muncul kembali.

Perlu diingat, daftar plugin yang bisa anda aktifkan dan non-aktitkan hanya muncul dari plu-
gin yang sudah Anda instal. Untuk menginstal plugin baru, Anda harus menggunakan Plugin
Installer.

10.1.2 i Ikuti Bersama: Menginstal Plugin Baru

* Untuk memulai Plugin Installer, klik pada item menu Plugins — Fetch Python Plugins.

Selanjutnya kotak dialog akan muncul. .Jumlah plugin yang Anda lihat akan berbeda, tergan-
tung dari pengaturan Anda.

Jumlah plugin yang Anda lihat akan berbeda, tergantung dari pengaturan Anda.
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Plugins QGIS disimpan secara online dalam repositori. Secara default, hanya repositori res-
mi yang aktif, yang berarti bahwa Anda hanya dapat mengakses plugin resmi. Plugin-plugin
ini biasanya , merupakan plugin awal yang Anda inginkan. Plugin-plugin tersebut telah diuji
secara keseluruhan dan biasanya masuk dalam default QGIS.

Walaupun demikian, Anda dapat mencari plugins yang lain selain plugin awal. Pertama, Anda
perlu mengecek terlebih dahulu pada repositori yang tersedia. Untuk melakukan ini:

* Buka tab Repositories ‘pada kotak dialog guilabel: ‘Plugin Installer:

: QGIS Python Plugin Installer - 21 plugins available L

Plugins | Repositories | Options

Status Name
-
[0l connected GIS-Lab Repository

| Add 3rd party repositories J

-d QGIS Official Repository
ed QGIS Official Repository 2

URL

http://pyqgis.org/repo/official
http://plugins.qgis.org/plugins/plugins.xml

http://gis-lab.info/programs/qgis/qgis-repo.xml

[ connected QGIS Contributed Repository http://pyqgis.org/repo/contributed

| Add...

Help The plugins will be installed to ~/.qgis/python/plugins

Edit...

Delete

Close

» Klik pada tombol Add 3rd party repositories. Pemberitahuan akan muncul.

* Klik OK untuk mencari dan tambahkan repositories tambahan ini:

: Fetching repositories L

Repository State ~
‘Carson Farmer's Repository  Success

Kappasys Repository Success

Barry Rowlingson's Repository  Success 3
GIS-Lab Repository success

Aaron Racicot's Repository Success

CatAlS Repository success |
QGIS Official Repository success

Martin Dobias’ Sandbox Success

QGIS Official Repository 2 Downloading data... -
Overall progress:

[ Abort Fetching J
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Akan tetapi, meskipun repositories tambahan ini telah diaktifkan, Anda tidak akan melihat
plugin yang ada didalamnya, kecuali Anda menginginkan plugin ini ditampilkan.

* Open the Options tab:

QGIS Python Plugin Installer - 21 plugins available

Plugins | Repositories | Options

Check For updates on startup

Allowed plugins
@® oOnly show plugins from the official repository

- Show all plugins except those marked as experimental

) Show all plugins, even those marked as experimental

MNote: Experimental plugins are generally unsuitable for production use. These plugins are in early stages of
development, and should be considered 'incomplete’ or 'proof of concept' tools. QGIS does not recommend installing
these plugins unless you intend te use them for testing purposes.

| Help | The plugins will beinstalled to ~/.qgis/python/plugins | Close |

* Pilih opsi Show all plugins except those marked as experimental.

 Jika Anda beralih kembali ke tab Plugins,Anda akan melihat lebih banyak plugin yang
tersedia untuk diinstal.

* Untuk menginstall satu plugin, cukup dengan mengklik salah satu plugin pada daftar dan
kemudian klik tombol Install plugin.

10.1.3 Kesimpulan

Menginstal plugins dalam QGIS mudah dan efektif!

10.1.4 Apa Selanjutnya?

Selanjutnya, Kami akan mengenalkan Anda beberapa contoh kegunaan plugin.

10.2 Pelajaran: Kegunaan Plugins QGIS

Sekarang anda dapat menginstal, mengaktifkan dan menonaktifkan plugin. Mari kita lihat
bagaimana hal ini dapat membantu Anda dalam melihat beberapa plugin yang bermanfaat.

Tujuan dari pelajaran ini : Untuk membiasakan diri Anda dengan antarmuka plugin dan
berkenalan dengan beberapa plugin yang bermanfaat.
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10.2.1 i Ikuti bersama: Plugin Raster Terrain Analysis

* Mulailah dengan peta baru yang hanya memuat dataset raster srem_41_19.tif di dalamnya

(lihat pada exercise_data/raster/SRTM).

Dari latihan tentang analisis raster, Anda diharapkan telah terbiasa dengan fungsi-fungsi analisi
raster. Anda telah menggunakan beberapa tooltool GDAL untuk hal ini (dapat diakses pada
Raster —> Analysis). Meskipun demikian, Anda juga harus mengetahui tentang plugin Raster
Terrain Analysis.Plugin ini merupakan satu paket standar pada versi QGIS yang terbaru, dan

Anda tidak perlu untuk menginstalnya secara terpisah.

* Buka Plugin Manager dan periksa apakah plugin Raster Terrain Analysis sudah aktif :

QGIS Plugin Manager L

Filter [

l

To enable / disable a plugin, click its checkbox or description

. QSpatiaLite (Version 6.0.2)

& - SpatiaLite GUI for SpatiaLite: load/export SpatiaLite
tables{Query to QGIS Canvas, Import DEF, ...
Installed in Plugins menu/toolbar

Raster Terrain Analysis plugin

A plugl;in For raster based terrain analysis
Installed in Raster menu/toolbar

RasterCalc (Version 0.2.4)
& i Perform raster algebra operations

Plugin Directory: fusrflocalflib/qgis/plugins

| selectAll || ClearAll || cancel || oK |

* Buka menu Raster, Anda seharusnya sudah dapat melihat submenu 7errain analysis.

* Klik pada Terrain analysis — Relief untuk dapat membuka kotak dialog di bawah ini:

10.2. Pelajaran: Kegunaan Plugins QGIS
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Oukput layer

Z Factor

Elevation layer

Output format

Relief colors

[T Add result to project

srtm_41_19 i

@

GeoTIFF - ]

)

[Creal:eaul:omal:ically] [Exparl:disl:ribul:ian...] [ Up J [ Down ] [ + ] [ . ]

Lower bound Upper bound | Color

[ Export colors... ] [

Import colors... J

Relief colors

Simpan file baru dengan nama exercise_data/plugins/relief.tif (buat fo-
lder baru apabila perlu).

Jangan ubah Output format dan Z factor.
Beri tanda centang pada kotak Add result to project.

Kemudian klik tombol Create automatically. Contohnya sebagai berikut :

_  Exportdistribution... | | uUp || Down || o+ || -

_—

Lower bound Upper bound Color

(v}
121.357
350.587
653.98
707.917
997.825
997.825
997.825
1436.06

121.357
350.587
653.98
707.917
997.825
997.825
997.825
1436.06
1699

Warna-warna tersebut yang akan digunakan oleh plugin untuk menggambarkan kenam-
pakan permukaan.

* Jika Anda ingin, Anda dapat mengubahnya. Contohnya sebagai berikut :
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Relief colors

Lower bound | Upper bound Color

0T sy

121.357 350.587

350.587 653.98

653.98 707.917

707.917 997.825

997.825 997.825

997.825 997.825

997.825 1436.06

1436.06 1699

e Klik :guilabel:*‘OK‘dan relief akan terbentuk:

Plugin ini menghasilkan efek yang sama seperti ketika Anda menggunakan hillshade semi-
transparan sebagai overlay di atas layer raster. Kelebihan dari plugin ini adalah efek dapat
dibuat dengan hanya menggunakan satu layer.

10.2.2 0 Ikuti bersama: Plugin Google Layers

* Buatlah peta baru dengan hanya layer streets di dalamnya.

* Perbesar pada Swellendem area.
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* Dengan mengunakan Plugin Installer, cari pluginnya dengan mengetik Google pada
field Filter.

* Pilih plugin Google Layers dari daftar :

QGIS Python Plugin Installer - 164 plugins available

‘ Plugins ‘ Repositories = Options
Filter: [Google l [all repositories :] [anysl:al:us :]
Status Name Version Description
not installed Openlayers Overview 0.1.7 Show area of map in browser with openlayers{(google maps and
not installed GeoCoding 2.3 GeoCoding and reverse GeoCoding using Google web services
notinstalled Elevation 0.1.0 Display point elevations in Google Maps
not installed GMap Overview 0.2 This plugin allows view an images of the Google Maps. You can
not installed GoogleLayers 0.7.2 Add Google Layers into QGIS
notinstalled OpenLayers Plugin  0.90 OpenstreetMap, Google Maps, Bing Maps layers and more
T 3 D)
Upgrade all _ Uninstall plugin
The plugins will be installed to ~/.qgis/python/plugins Close

* Klik tombol Install plugin untuk menginstal.
* Apabila sudah selesai, tutup Plugin Installer.
* Buka Plugin Manager.

» Aktifkan plugin baru:

QGIS Plugin Manager =

Filter [ l

To enable / disable a plugin, click its checkbox or description

Georeferencer GDAL =

[ = Georeferencingrasters using GDAL
- Installed in Raster menu/toolbar

~—, Google Layers (Version 0.7.2)
Add Google Layers into QGIS

Installed in Plugins menu/ftoolbar

Heatmap

]  Createsa Heatmap raster for the input point vector
- Installed in Raster menu/ftoolbar

Interpolation plugin
B m A plugin for interpolation based on vertices of a vector layer -

Plugin Directory: /usrflocal/lib/qgis/plugins

| SelectAll || clearall || cancel |[ oK |
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* Centang pada kotak yang ada disamping .
* kemudian klik OK untuk dapat mengaktifkan plugin.

Sebelum menggunakan ini, pastikan baik peta Anda maupun pluginnya terkonfigurasi secara
benar:

* Buka pengaturan plugin dengan mengklik pada Plugins — Google Layers — Settings.

* Gunakan kotak dialog untuk memilih tipe peta mana yang Anda inginkan. Untuk contoh
kali ini, kita akan menggunakan tipe peta “Hybrid”, tetapi Anda dapat memilih tipe yang
lain sesuai keinginan Anda.

» Aktifkan proyeksi “on the fly”” dan sistem proyeksi Google Mercator:

: Project Properties )

% General | § Coordinate Reference System (CRS) | [F%] Identifiable layer * H

& Enable 'on the fly' CRS transformation

Filter |.google

Recently used coordinate references systems

Coordinate Reference System Authority ID

Google Mercator EPSG:900913

<|: T N ¥

Coordinate reference systems of the world [ ] Hide deprecated CRSs
Coordinate Reference System Authority ID
v [ Projected Coordinate Systems
¥ Mercator
GDDglE Mercator EPS5G:900913
4 I: T N ¥
+proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 b
+y_0=0+k=1.0 +units=m +nadgrids=@null +wktext +over +no_defs -

__tHelp _Apply | cancel |[ oK |

» Sekarang gunakan plugin untuk memberikan Anda tampila Google map pada area terse-
but. Untuk menjalankannya, Anda dapat mengklik pada Plugins — Google Layers —
Google Layers, Atau jika Toolbar Plugin Anda aktif, Anda dapat mengklik ikon plugin
berikut:
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Plugin ini akan memuat tampilan raster baru dari Google yang dapat Anda gunakan sebagai
latar belakang peta, atau membantu Anda untuk mencari lokasi Anda barada pada peta. Dalam
latihan kita, layer street akan ditampilkan sebagai overlay.:

10.2.3 “" Ikuti Bersama: Plugin OpenStreetMap

Karena kita menggunakan data OpenStreetMap (OSM) sebagai contoh, akan bermanfaat apa-
bila kita mengetahui dari mana asalnya . QGIS memiliki plugin yang memungkinkan Anda
untuk mendownload dan mengedit jenis data dengan mudah.

* Pertama, Pastikan bahwa plugin Anda telah terinstal dengan cara membuka Plugin Insta-
ller dan seleksi dengan kata st reet:
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QGIS Python Plugin Installer - 164 plugins available L]

| Plugins | Repositories | Options

Filter: |:street | [all repositories ;J [anystatus :J
Status Name Version | Description

not installed OpenLayers Plugin 0.90 OpensStreetMap, Google Maps, Bing Maps lay
installed OpenstreetMap plugin 0.5 Viewer and editor for OpenStreetMap data

i i ] 3
Upgrade all Install/upgrade plugin | | Uninstall plugin

Help The plugins will be installed to ~/.qgis/python/plugins Close

* Secara default, seharusnya plugin OpenStreetMap plugin sudah terinstal, tetapi apabila
belum, Anda bisa mendapatkannya dengan cara mengklik tombol Install plugin.

* Setelah terinstal, aktifkan melalui Plugin Manager.

¢ Panel dan tombol-tombol baru akan ditambahkan ke antarmuka Anda:

OSM Feature EIRF
[0 & o ..: .: 2 (e Y] e
Feature:

TYPE, ID:

CREATED

USER i

Properties | Relations
!
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Selanjutnyakita akan mendownload data untuk Swellendam. Plugin akan mendownload area
yang saat ini ditampilkan di peta.

¢ Perbesar ke area Swellendam.

* Untuk menambahkan data, klik pada tombol Download OSM data:

B!

Catatan: Anda mungkin akan melihat pesan yang menyatakan bahwa garis lintang, bujur,
atau kedua luasan terlalu besar. Hal ini terjadi karena server OSM tidak memiliki kapasitas

untuk terus memberikan data kepada banyak pengguna data seluruh dunia. Untuk mencegah
orang yang mencoba untuk men-download data terlalu banyak, ada batasan untuk ukuran area
yang Anda download . Jika Anda mendapatkan satu pesan error, perbesar pada area yang lebih
kecil pada peta.

* Jika luas area Anda dapat diterima, Anda dapat membiarkan opsi lain sebagaimana defa-
ultnya dan klik tombol Download.

* Setelah beberapa saat, data akan diunduh, dan akan ditampilkan di peta Anda secara
otomatis. Berikut ini contohnya:

J

|

< African Shades

%;llend‘am
X 7

&

b, 8
V \
/ \
s i

Bloomestate / ./ b
e 'Jr'f \'x

/ SN N e - P

(Label ditambahkan dari data lokal dan untuk tujuan identifikasi.)
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Dengan salah satu layer OSM dalam keadaan terpilih pada Layers list,tombol-tombol di dock
panel plugin akan menjadi aktif:

OSM Feakture (&) [
52) (&) (o] (=2 (23] (28] | [~ @)
Feature:

TYPE, 1D:
CREATED:
USER: r

* Dengan menggunakan tool Identify feature (di bagian paling kiri dari tombol di atas),
klik pada setiap fitur di layer OSM untuk mengambil data dan memanpilkannya dalam
jendela plugin. Misalnya, Dengan mengklik pada sungai yang mengalir melalui kota
akan member Anda informasi berikut:

Properties | Relations

Key Value
1 name ............................. ool
2 source survey and 1943 1:50K ...
3 waterway river

4 =newtagh...

* Anda dapat membuat fitur baru (point, line, polygon) dan Anda dapat juga mengedit fitur
yang sudah Anda identifikasi. Sebagai contoh,dengan menggunakan tool plugin yaitu
tool Identify feature, Klik pada jalan ini:
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\ Swellendam

Lihat atribut pada layer jalan, tidak ada nama di dalamnya:

‘ Properties | Relations

Key Value

2 <new tag here>

 Klik dua kali pada kolom <new tag here>.

* Pilih tag baru (attribut) dari daftar. Mari kita pilih name:
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Properties | Relations

Key Value

1 highway residential
2 name
3 <new tag here>

 Klik dua kali pada field Value:

Properties | Relations

Key Value
1 highway residential
2 name Kanonsktraat

3 <newtag here>

Anda dapat menyimpan perubahan Anda pada data aslinya juga. Perubahan yang Anda buat
akan tersedia secara internasional pada server OSM.

B

Kemudian akan muncul dialog, yang dapat Anda isi sesuai kebutuhan.

» Klik tombol Upload OSM data:

 Jika Anda memiliki akun pengguna OSM, Anda dapat memasukkan info Anda pada
tempat yang disediakan dan klik tombol Upload untuk menyimpan perubahan tersebut.

Sebagai catatan, plugin memiliki banyak fungsi : contohnya, Anda juga dapat menyimpan
layer osm ke direktori lokal, memuat data dari layer OSM yang tersimpan, and mengekspor
data OSM sebagai shapefile.

Data OSM berasal dan dipelihara oleh semua pengguna. Memberi masukan data dengan meng-
gunakan plugin ini dapat membantu meningkatkan kualitas data OSM.

10.2.4 Kesimpulan

Terdapat banyak plugin yang bermanfaat yang tersedia untuk QGIS. Dengan menggunakan
tool built-in untuk menginstal dan mengelola plugin, Anda dapat menemukan plugin baru dan
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memanfaatkan plugin tersebut secara optimal.

10.2.5 Apa Selanjutnya?

Selanjutnya, kita akan melihat bagaimana menggunakan layer yang disediakan di remote server
secara seketika.
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