
CHAPTER 8

Module: Rasters

We’ve used rasters for digitizing before, but raster data can also be used directly. In this module,

you’ll see how it’s done in QGIS.

8.1 Lesson: Working with Raster Data

Raster data is quite different from vector data. Vector data has discrete features constructed out

of vertices, and perhaps connected with lines and/or areas. Raster data, however, is like any

image. Although it may portray various properties of objects in the real world, these objects

don’t exist as separate objects; rather, they are represented using pixels of various different

color values.

During this module you’re going to use raster data to supplement your existing GIS analysis.

The goal for this lesson: To learn how to work with raster data in the QGIS environment.

8.1.1 Follow along: Loading Raster Data

• Open your analysis.qgs map.

• Deactivate all the layers except the solution and important_roads layers.

• Click on the Load Raster Layer button:

The Load Raster Layer dialog will open. The data for this project is in

exercise_data/rasters.

• Either load them all in separately, or hold down ctrl and click on all four of them in

turn, then open them at the same time.

The first thing you’ll notice is that nothing seems to be happening in your map. Are the rasters

not loading? Well, there they are in the Layers list, so obviously they did load. The problem is

that they’re not in the same projection. Luckily, we’ve already seen what to do in this situation.
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• Click on the CRS Status button:

• Enable “on the fly” reprojection.

• Set it to the same projection as the rest of your data (WGS 84 / UTM zone 33S).

• Click OK.

The rasters should fit nicely:

There we have it - four aerial photographs covering our whole study area.

8.1.2 Follow along: Create a Virtual Raster

Now as you can see from this, your solution layer lies across all four photographs. What this

means is that you’re going to have to work with four rasters all the time. That’s not ideal; it
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would be better to have one file for one (composite) image, right?

Luckily, QGIS allows you to do exactly this, and without needing to actually create a new raster

file, which could take up a lot of space. Instead, you can create a Virtual Raster. This is also

often called a Catalog, which explains its function. It’s not really a new raster. Rather, it’s a

way to organize your existing rasters into one catalog: one file for easy access.

To make a catalog:

• Click on the menu item Raster → Miscellaneous → Build Virtual Raster (Catalog).

• In the dialog that appears, check the box next to Use visible raster layers for input.

• Anter exercise_data/residential_development as the output location.

• Enter aerial_photos.vrt as the file name.

• Check the Load into canvas when finished button.

Notice the text field below. What this dialog is actually doing is that it’s writing that text for

you. It’s a long command that QGIS is going to run.

Note: Keep in mind that the command text is editable, so you can customize
the command further if preferred. Search online for the initial command (in this case,

gdalbuildvrt) for help on the syntax.

• Click OK to run the command.

It may take a while to complete. When it’s done, it will tell you so with a message box.

• Click OK to chase the message away.

• Click Close on the Build Virtual Raster (Catalog) dialog. (Don’t click OK again, other-

wise it’s going to start running that command again!)

• You can now remove the original four rasters from the Layers list.

• If necessary, click and drag the new aerial_photos raster catalog layer to the bottom of

the Layers list so that the other activated layers become visible.

8.1.3 Transforming Raster Data

The above methods allow you to virtually merge datasets using a catalog, and to reproject them

“on the fly”. However, if you are setting up data that you’ll be using for quite a while, it may

be more efficient to create new rasters that are already merged and reprojected. This improves

performance while using the rasters in a map, but it may take some time to set up initially.

Reprojecting rasters

• Click on the menu item Raster → Projection → Warp (Reproject).
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Note that this tool features a handy batch option for reprojecting the contents of whole direc-

tories. You can also reproject virtual rasters (catalogs), as well as enabling a multithreaded

processing mode.

Merging rasters

• Click on the menu item Raster → Miscellaneous → Merge.

You can choose to process entire directories instead of single files, giving you a very useful

built-in batch processing capability. You can specify a virtual raster as input file, too, and all of

the rasters that it consists of will be processed.

You can also add your own command line options using the Creation Options checkbox and

list. This only applies if you have knowledge of the GDAL library’s operation.

8.1.4 In conclusion

QGIS makes it easy to include raster data into your existing projects.

8.1.5 What’s next?

Next, we’ll use raster data that isn’t aerial imagery, and see how symbolization is useful in the

case of rasters as well!

8.2 Lesson: Changing Raster Symbology

Not all raster data consists of aerial photographs. There are many other forms of raster data,

and in many of those cases, it’s essential to symbolize the data properly so that it becomes

properly visible and useful.

The goal for this lesson: To change the symbology for a raster layer.

8.2.1 Try yourself...

• Use the Add Raster Layer button to load the new raster dataset.

• Into your current map (which, following from the previous lesson, should be

analysis.qgs) load the dataset srtm_41_19.tif, found under the directory

exercise_data/raster/SRTM/.

• Once it appears in the Layers list, rename it to DEM.

This dataset is a Digital Elevation Model (DEM). It’s a map of the elevation (altitude) of the

terrain, allowing us to see where the mountains and valleys are, for example.
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Once it’s loaded, you’ll notice that it’s basically a gray rectangle. It’s seen here with the vector

layers on top:

That’s because its symbology hasn’t been customized. In a color aerial photograph, everything

is already defined. But if you load a raster and it’s just a gray rectangle, then you know there’s

no symbology for it yet. It still needs to be defined. So that’s what you should do next.

8.2.2 Follow along: Changing Raster Layer Symbology

• Open the Layer Properties dialog for the SRTM layer.

• Switch to the Style tab.

These are the current settings, and as we’ve seen, they don’t give us much information on the

layer. Does it even have any data in it? Let’s see.

• Change the Color map to Pseudocolor:
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• Click OK.

You’ll see the raster looking like this:

That does tell us what we need to know. There is data in this layer. But maybe we don’t want

to symbolize it using these colors.

• Open Layer Properties again.

• Switch the Color map back to Grayscale.

226 Chapter 8. Module: Rasters



Quantum GIS Training Manual, Release 1.0

But this time, to prevent it from becoming a gray rectangle again, let’s tell QGIS to “stretch”

the color values. This will make QGIS use all of the available colors (in Grayscale, this is

black, white and all shades of gray in between).

• Tell it to use Custom min / max values:

• Set the value Current of Contrast enhancement to Stretch To MinMax:

But what are the minimum and maximum values that should be used for the stretch? The

ones that are currently under Custom min / max values are the same values that just gave us a

gray rectangle before. Instead, we should be using the minimum and maximum values that are

actually in the image, right? Fortunately, you can determine those values easily by loading the

minimum and maximum values of the raster.

• Under Load min / max values from band, select Estimate (faster).

• Click the Load button:

Notice how the Custom min / max values have changed:

• Click OK.

You’ll see the values of the raster properly displayed, with the darker colors representing valleys

and the lighter ones, mountains:
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But isn’t there a quicker way?

Yes, there is! Now that you understand what needs to be done, you’ll be glad to know that

there’s a tool for doing all of this easily.

• Remove the current DEM from the Layers list.

• Load the raster in again, renaming it to DEM as before. It’s a gray rectangle again...

• Enable the tool you’ll need by enabling View → Toolbars → Raster. These icons will

appear in the interface:

The button on the right will stretch the minimum and maximum values to give you the best

contrast in the local area that you’re zoomed into. It’s useful for large datasets. The button

on the left will stretch the minimum and maximum values to constant values across the whole

image.

• Click the button on the left (Stretch Histogram to Full Dataset). You’ll see the data is

now correctly represented as before!
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8.2.3 In conclusion

These are only the basic functions to get you started with raster symbology. QGIS also allows

you many other options, such as symbolizing a layer using standard deviations, or representing

different bands with different colors in a multispectral image.

8.2.4 Reference

The SRTM dataset was obtained from http://srtm.csi.cgiar.org/

8.2.5 What’s next?

Now that we can see our data displayed properly, let’s investigate how we can analyze it further.

8.3 Lesson: Terrain Analysis

Certain types of rasters allow you to gain more insight into the terrain that they represent.

Digital Elevation Models (DEMs) are particularly useful in this regard. In this lesson you will

use terrain analysis tools to find out more about the study area for the proposed residential

development from earlier.

The goal for this lesson: To use terrain analysis tools for more information on terrain.

8.3.1 Follow along: Calculating a Hillshade

The DEM you have on your map right now does show you the elevation of the terrain, but it

can sometimes seem a little abstract. It contains all the 3D information about the terrain that

you need, but it doesn’t look like a 3D object. To get a better look at the terrain, it is possible

to calculate a hillshade, which is a raster that maps the terrain using light and shadow to create

a 3D-looking image.

To work with DEMs, you should use QGIS’ all-in-one DEM (Terrain models) analysis tool.

• Click on the menu item Raster → Analysis → DEM (Terrain models).

• In the dialog that appears, ensure that the Input file is the DEM layer.

• Set the Output file to hillshade.tif in the directory

exercise_data/residential_development.

• Check the box next to Load into canvas when finished.

• You may leave all the other options unchanged.

• Click OK to generate the hillshade.

• When it tells you that processing is completed, click OK on the message to get rid of it.
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• Click Close on the main DEM (Terrain models) dialog.

You will now have a new layer called hillshade that looks like this:

That looks nice and 3D, but can we improve on this? On its own, the hillshade looks like a

plaster cast. Can’t we use it together with our other, more colorful rasters somehow? Of course

we can, by using the hillshade as an overlay.

8.3.2 Follow along: Using a Hillshade as an Overlay

A hillshade can provide very useful information about the sunlight at a given time of day. But

it can also be used for aesthetic purposes, to make the map look better. The key to this is setting

the hillshade to being mostly transparent.

• Change the symbology of the original DEM to use the Pseudocolor scheme.

• Hide all the layers except the DEM and hillshade layers.

• Click and drag the DEM to be beneath the hillshade layer in the Layers list. Control

rendering order (beneath the list) should be checked as well.

• Set the hillshade layer to be transparent.

• Open its Layer Properties and go to the Transparency tab.
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• Set the Global transparency to 50%:

• Click OK on the Layer Properties dialog. You’ll get a result like this:

• Switch the hillshade layer off and back on in the Layers list to see the difference it makes.

Using a hillshade in this way, it’s possible to enhance the topography of the landscape. If the

effect doesn’t seem strong enough to you, you can change the transparency of the hillshade

layer; but of course, the brighter the hillshade becomes, the dimmer the colors behind it will

be. You will need to find a balance that works for you.

Remember to save your map when you are done.

Note: For the next two exercises, please use a new map. Load only the DEM raster
dataset into it (exercise_data/raster/SRTM/srtm_41_19.tif). This is to sim-

plify matters while you’re working with the raster analysis tools. Save the map as

exercise_data/raster_analysis.qgs.

8.3.3 Follow along: Calculating the Slope

Another useful thing to know about the terrain is how steep it is. If, as in our analysis, you want

to build houses on the land there, then you need land that is relatively flat.

To do this, you need to use the Slope mode of the DEM (Terain models) tool.

• Open the tool as before.
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• Select the Mode option Slope:

• Set the save location to exercise_data/residential_development/slope.tif

• Enable the Load into canvas... checkbox.

• Click OK and close the dialog when processing is complete. You’ll see a new raster
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loaded into your map.

• With the new raster selected in the Layers list, click the Stretch Histogram to Full Dataset

button. Now you’ll see the slope of the terrain, with black pixels being flat terrain and

white pixels, steep terrain:

8.3.4 Try yourself... calculating the aspect

The aspect of terrain refers to the direction it’s facing in. Since this study is taking place in the

Southern Hemisphere, properties should ideally be built on a north-facing slope so that they

can remain in the sunlight.

• Use the Aspect mode of the DEM (Terain models) tool to calculate the aspect of the

terrain.

Check your results

8.3.5 Follow along: Using the Raster Calculator

Think back to the residential property development problem, which we last addressed in the

Vector Analysis lesson. So far, you’ve identified several farms that would be suitable, but

without taking the terrain into account. Let’s say that an ideal farm for development needs to
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have areas on it that are north-facing, and with a slope of less than five degrees. But if the slope

is less than 2 degrees, then the aspect doesn’t matter.

Fortunately, you already have rasters showing you the slope as well as the aspect, but you have

no way of knowing where both conditions are satisfied at once. How could this analysis be

done?

The answer lies with the Raster calculator.

• Click on Raster > Raster calculator... to start this tool.

• To make use of the aspect dataset, double-click on the item aspect@1 in the Raster bands

list on the left. It will appear in the Raster calculator expression text field below.

North is at 0 (zero) degrees, so for the terrain to face north, its aspect needs to be greater than

270 degrees and less than 90 degrees.

• In the Raster calculator expression field, enter this expression:

aspect@1 <= 90 OR aspect@1 >= 270

• Set the output file to aspect_north.tif in the directory

exercise_data/residential_development/.

• Ensure that the box Add result to project is checked.

• Click OK to begin processing.

Your result will be this:
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8.3.6 Try yourself...

Now that you’ve done the aspect, create two separate new analyses of the DEM layer.

• The first will be to identify all areas where the slope is less than or equal to 2 degrees.

• The second is similar, but the slope should be less than or equal to 5 degrees.

• Save them under exercise_data/residential_development/ as

slope_lte2.tif and slope_lte5.tif.

Check your results

8.3.7 Follow along: Combining Raster Analysis Results

Now you have three new analysis rasters of the DEM layer:

• aspect_north: the terrain faces north

• slope_lte2: the slope is at or below 2 degrees

• slope_lte5: the slope is at or below 5 degrees
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Where the conditions of these layers are met, they are equal to 1. Elsewhere, they are equal to

0. Therefore, if you multiply one of these rasters by another one, you will get the areas where

both of them are equal to 1.

The conditions to be met are: at or below 5 degrees of slope, the terrain must face north; but at

or below 2 degrees of slope, the direction that the terrain faces in does not matter.

Therefore, you need to find areas where the slope is at or below 5 degrees AND the terrain

is facing north; OR the slope is at or below 2 degrees. Such terrain would be suitable for

development.

To calculate the areas that satisfy these criteria:

• Open your Raster calculator again.

• Use the Raster bands list, the Operators buttons, and your keyboard to build this expres-

sion in the Raster calculator expression text area:

( aspect_north@1 = 1 AND slope_lte5@1 = 1 ) OR

slope_lte2@1 = 1

• Save the output under exercise_data/residential_development/ as

all_conditions.tif.

• Click OK on the Raster calculator. Your results:
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8.3.8 Follow along: Simplifying the Raster

As you can see from the image above, the combined analysis has left us with many, very small

areas where the conditions are met. But these aren’t really useful for our analysis, since they’re

too small to build anything on. Let’s get rid of all these tiny unusable areas.

• Open the Sieve tool (Raster → Analysis → Sieve).

• Set the Input file to all_conditions, and the Out-

put file to all_conditions_sieve.tif (under

exercise_data/residential_development/).

• Set both the Threshold and Pixel connections values to 8, then run the tool.

Once processing is done, the new layer will load into the canvas. But when you try to use the

histogram stretch tool to view the data, this happens:

What’s going on? The answer lies in the new raster file’s metadata.

• View the metadata under the Metadata tab of the Layer Properties dialog.

Whereas this raster, like the one it’s derived from, should only feature the values 1 and 0, it has

the STATISTICS_MINIMUM value of a very large negative number. Investigation of the data

shows that this number acts as a null value. Since we’re only after areas that weren’t filtered

out, let’s set these null values to zero.

• Open the Raster Calculator again, and build this expression:

(all_conditions_sieve@1 <= 0) = 0
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This will maintain all existing zero values, while also setting the negative numbers to

zero; which will leave all the areas with value 1 intact.

• Save the output under exercise_data/residential_development/ as

all_conditions_simple.tif.

Your output looks like this:

This is what was expected: a simplified version of the earlier results. Remember that if the re-

sults you get from a tool aren’t what you expected, viewing the metadata (and vector attributes,

if applicable) can prove essential to solving the problem.

8.3.9 In conclusion

You’ve seen how to derive all kinds of analysis products from a DEM. These include hillshade,

slope and aspect calculations. You’ve also seen how to use the raster calculator to further

analyze and combine these results.

8.3.10 What’s next?

Now you have two analyses: the vector analysis which shows you the potentially suitable

farms, and the raster analysis that shows you the potentially suitable terrain. How can these

be combined to arrive at a final result for this problem? That’s the topic for the next lesson,

starting in the next module.
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