cHAPTER 10

Module: Plugins

Plugins allow you to extend the functionality QGIS offers. In this module, you’ll be shown
how to activate and use plugins.

10.1 Lesson: Installing and Managing Plugins

To begin using plugins, you need to know how to download, install and activate them. To do
this, you will learn how to use the Plugin Installer and Plugin Manager.

The goal for this lesson: To understand and use QGIS’ plugin system.

10.1.1 V} Follow along: Managing Plugins

* To open the Plugin Manager, click on the menu item Plugins — Manage Plugins.

* In the dialog that opens, find the GdalTools plugin:
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QGIS Plugin Manager .

Filter [ l

To enable / disable a plugin, click its checkbox or description

4. DxF2shp Converter
0 % Converts from dxF to shp file format

GPS Tools :]
M Tools for loading and importing GPS data ]

GdalTools (Version 1.2.29)
& I Integrate gdal tools into qgis

Georeferencer GDAL

(] — Georeferencingrasters using GDAL
Heatmap
] Creates a Heatmap raster for the input point vector

Interpolation plugin
— dkJ

A mliain Far inkarmalabioan bhaeod sanousckicoe aF sossebor Laese

Plugin Directory: /home/rudi/apps/qagis-1_8/lib/qgis/plugins

| selectAll | | clearAll || cancel || oK |

* Click in the box next to this plugin and uncheck it.

* Click OK.

* Look under the Raster menu. You will see that many of the functions you have been
using before have disappeared! This is because they are part of the GdalTools plugin,
which needs to be activated for you to use them.

* Open the Plugin Manager again and reactivate the GdalTools plugin by clicking in the
checkbox next to it.

* If you open the Raster menu again, you’ll see that the tools have reappeared.

Importantly, however, the list of plugins that you can activate and deactivate only draws from
the plugins that you currently have installed. To install new plugins, you need to use the Plugin
Installer.

10.1.2 " Follow along: Installing New Plugins

* To start the Plugin Installer, click on the menu item Plugins — Fetch Python Plugins.

A dialog will appear. The amount of plugins that you see here will differ, depending on your
setup.

The plugins that are available to you for installation depend on which repositories you are
checking.
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QGIS plugins are stored online in repositories. By default, only the official repositories are
active, meaning that you can only access official plugins. These are usually the first plugins
you want, because they have been tested thoroughly and are often included in QGIS by default.

It is possible, however, to try out more plugins than the default ones. First, you want to check
in all available repositories. To do this:

* Open the Repositories tab on the Plugin Installer dialog:

: QGIS Python Plugin Installer - 21 plugins available L

Plugins | Repositories | Options

Sta Name
oF
O]

[l connected GIS-Lab Repository

| Add 3rd party repositories J

URL

QGIS Official Repository http://pyqgis.org/repo/official
QGIS Official Repository 2 http://plugins.qgis.org/plugins/plugins.xml

http://gis-lab.info/programs/qgis/qgis-repo.xml

@] connected QGIS Contributed Repository http://pyqgis.org/repo/contributed

| Add..

Help The plugins will be installed to ~/.qgis/python/plugins

Edit...

Delete

Close

* Click the Add 3rd party repositories button. A disclaimer will appear.

* Click OK to find and add these extra repositories:

: Fetching repositories L

Repository State ~
‘Carson Farmer's Repository . Success

Kappasys Repository Success

Barry Rowlingson's Repository  Success 3
GIS-Lab Repository Success

Aaron Racicot's Repository success

CatAlS Repository sSuccess X
QGIS Official Repository Success

Martin Dobias' Sandbox sSuccess

QGIS Official Repository 2 Downloading data... -
Overall progress:

[ Abort Fetching J
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However, even with these extra repositories enabled, you won’t see the plugins that they con-
tain, unless you allow these plugins to be displayed.

* Open the Options tab:

QGIS Python Plugin Installer - 21 plugins available

Plugins | Repositories | Options

Check For updates on startup

Allowed plugins
@® oOnly show plugins from the official repository

- Show all plugins except those marked as experimental

) Show all plugins, even those marked as experimental

MNote: Experimental plugins are generally unsuitable for production use. These plugins are in early stages of
development, and should be considered 'incomplete’ or 'proof of concept' tools. QGIS does not recommend installing
these plugins unless you intend te use them for testing purposes.

| Help | The plugins will beinstalled to ~/.qgis/python/plugins | Close |

* Select the option Show all plugins except those marked as experimental.

* If you now switch back to the Plugins tab, you will see that many more plugins are now
available for installation.

* To install a plugin, simply click on it in the list and then click the Install plugin button.

10.1.3 In conclusion

Installing plugins in QGIS is simple and effective!

10.1.4 What’s next?

Next we’ll introduce you to some useful plugins as examples.

10.2 Lesson: Useful QGIS Plugins

Now you can install, enable and disable plugins. Let’s see how this can help you in practice by
looking at some examples of useful plugins.

The goal for this lesson: To familiarize yourself with the plugin interface and get acquainted
with some useful plugins.
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10.2.1 & Follow along: The Raster Terrain Analysis Plugin

e Start a new map with only the srtm_41_19.tif raster dataset in it (look in
exercise_data/raster/SRTM).

From the lesson on raster analysis, you're already familiar with raster analysis functions. You
used GDAL tools (accessible via Raster —> Analysis) for this. However, you should also know
about the Raster Terrain Analysis plugin. This ships standard with newer versions of QGIS,
and so you don’t need to install it separately.

* Open the Plugin Manager and check that the Raster Terrain Analysis plugin is enabled:

QGIS Plugin Manager

Filter [

To enable / disable a plugin, click its checkbox or description

‘ QSpatiaLite (Version 6.0.2) I
& -

SpatiaLite GUI for SpatiaLite: load/export SpatiaLite
tahles{Query to %GIS Canvas, Import DBF, ...
Installed in Plugins menu/toolbar

Raster Terrain Analysis plugin

A plu:l;in For raster based terrain analysis
Installed in Raster menu/toolbar

RasterCalc (Version 0.2.4)
& i Perform raster algebra operations -

Plugin Directory: fusrflocalflib/qgis/plugins

| selectAll || ClearAll || cancel || oK |

* Open the Raster menu. You should see a Terrain analysis submenu.

* Click on Terrain analysis — Relief to open this dialog:
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Oukput layer

Z Factor

Elevation layer

Output format

Relief colors

[T Add result to project

srtm_41_19 i

| )

GeoTIFF - ]

[Creal:eaul:omal:ically] [Exporl:disl:ribul:ian...] [ Up ] [ Down ] [ + ] [ - ]

Lower bound Upper bound | Color

[ Export colors... ] [

Import colors... ]

folder if necessary).

Relief colors

Save the new file under exercise_data/plugins/relief.tif (create a new

Leave the Output format and Z factor unchanged.
Check the box Add result to project.

Click the Create automatically button. The list below will be populated:

_ [Exporl:disl:rihul:ion...] [ Up ] [ Down ] [ + ] [ =

_—

Lower bound Upper bound Color

(v}
121.357
350.587
653.98
707.917
997.825
997.825
997.825
1436.06

121.357
350.587
653.98
707.917
997.825
997.825
997.825
1436.06
1699

These are the colors that the plugin will use to create the relief.

* If you like, you can change these colors now. For example:
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Relief colors

Lower bound | Upper bound Color

O 121.357
121.357  350.587
350.587  653.98
653.98  707.917
707.917  997.825
997.825  997.825
997.825  997.825
997.825  1436.06
1436.06 1699

¢ Click OK and the relief will be created:

This achieves a similar effect to when you used the semi-transparent hillshade as an overlay
over another raster layer. The advantage of this plugin is that it creates this effect using only
one layer.

10.2.2 0 Follow along: The Google Layers Plugin

* Start a new map with only the streets layer in it.

e Zoom in over the Swellendam area.
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* Using the Plugin Installer, find the plugin by entering the word Google in the Filter
field.

 Select the Google Layers plugin from the filtered list:

QGIS Python Plugin Installer - 164 plugins available

‘ Plugins ‘ Repositories = Options
Filter: [Google l [all repositories :] [anysl:al:us :]
Status Name Version Description
not installed Openlayers Overview 0.1.7 Show area of map in browser with openlayers{(google maps and
not installed GeoCoding 2.3 GeoCoding and reverse GeoCoding using Google web services
notinstalled Elevation 0.1.0 Display point elevations in Google Maps
not installed GMap Overview 0.2 This plugin allows view an images of the Google Maps. You can
not installed GoogleLayers 0.7.2 Add Google Layers into QGIS
notinstalled OpenLayers Plugin  0.90 OpenstreetMap, Google Maps, Bing Maps layers and more
T 3 D)
Upgrade all _ Uninstall plugin
The plugins will be installed to ~/.qgis/python/plugins Close

* Click the Install plugin button to install.
* When it’s done, close the Plugin Installer.
* Open the Plugin Manager.

* Enable the new plugin:

QGIS Plugin Manager =

Filter [ l

To enable / disable a plugin, click its checkbox or description

Georeferencer GDAL =

[ = Georeferencingrasters using GDAL
- Installed in Raster menu/toolbar

~—, Google Layers (Version 0.7.2)
Add Google Layers into QGIS

Installed in Plugins menu/ftoolbar

Heatmap

]  Createsa Heatmap raster for the input point vector
- Installed in Raster menu/ftoolbar

Interpolation plugin
B m A plugin for interpolation based on vertices of a vector layer -

Plugin Directory: /usrflocal/lib/qgis/plugins

| SelectAll || clearall || cancel |[ oK |
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¢ Check the box beside it.

* Now click OK to enable the plugin.

Before using it, make sure that both your map and the plugin are configured properly:

* Open the plugin’s settings by clicking on Plugins — Google Layers — Settings.

Help _Apply | cancel |[ oK |

Use the dialog to choose a map type you want. In this example, we’ll use the “Hybrid”
type map, but you can choose any others if you want.

Enable “on the fly” projection and use the Google Mercator projection:

Project Properties L]

% General | § Coordinate Reference System (CRS) | [F%] Identifiable layer * H

B Enable 'on the fly' CRS transformation

Filter | google |

Recently used coordinate references systems

Coordinate Reference System Authority ID

Google Mercator EPSG:900913

o i 3 »

Coordinate reference systems of the world [ ] Hide deprecated CRSs
Coordinate Reference System Authority ID
v [ Projected Coordinate Systems
v Mercator
Google Mercator EPSG:900913
(0 T »
+proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0 +x_0=0.0 b
+y_0=0+k=1.0 +units=m +nadgrids=@null +wktext +over +no_defs -

* Now use the plugin to give you a Google map of the area! You can click on Plugins —

Google Layers — Google Layers to run it. Or, if you have the Plugins toolbar enabled,
you can click on its icon:

‘. N
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This will load a new raster image in from Google that you can use as a backdrop, or to help
you find out where you are on the map. Here is such a layer, with our own vector road layer as
overlay:

10.2.3 " Follow along: The OpenStreetMap Plugin

Since we’re using OpenStreetMap (OSM) data in our examples, it would be instructive to know
where it comes from. QGIS has a plugin that allows you to download and edit this kind of data
easily.

* First, ensure that you have the plugin installed by opening the Plugin Installer and filter-
ing on the word street:
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| Plugins | Repositories | Options
Filter: |:street

Status Name

not installed OpenLayers Plugin 0.90
installed OpenstreetMap plugin 0.5

QGIS Python Plugin Installer - 164 plugins available L]

| [all repositories ;J [anystatus :J

Version | Description

OpensStreetMap, Google Maps, Bing Maps lay
Viewer and editor for OpenStreetMap data

] )
Upgrade all Install/upgrade plugin | | Uninstall plugin
Help | The plugins will be installed to ~/.qgis/python/plugins Close |

The OpenStreetMap plugin should be installed by default, but if it isn’t, you can get it by
clicking the Install plugin button.

Once it’s installed, activate it via the Plugin Manager.

* A new panel and new buttons will be added to your interface:

OSM Feature () (]
DO || [0 |&£] (o] 52| [ [ &
Feature:

TYPE, ID:

CREATED:

USER: H

Properties | Relations
!

10.2. Lesson: Useful QGIS Plugins
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Let’s download data for Swellendam. The plugin will download data for the area currently on
your map.

e Zoom in to the Swellendam area.

* To add data, click on the Download OSM data button:

B

Note: You may see a message stating that the latitude, longitude, or both extents are too large.
This is because the OSM server doesn’t have the capacity to continually give people data about

the whole world. To prevent people trying to download too much data, there’s a limit to the
size of the area for which you can download data. If you get one of these error messages, zoom
in to a smaller area on the map.

* If you have an acceptable area, you can leave the other options as default and click the
Download button.

» After a while, the data will be downloaded, and will be shown in your map automatically.
Here’s an example:

j_faoméstaty o
g f

i

\

pmm————

i

(The labels are added from our local data for identification purposes.)
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With any of the OSM layers selected in your Layers list, the buttons in the plugin’s dock panel
will become active:

OSM Feakture [%¢]

52 @ (o) (=5) 28 §&) = |~ (&
Fealure:
TYPE, 1D:
CREATED:
USER: ti5
» Using the plugin’s own Identify feature tool (at the far left of the above buttons), click

on any feature in the OSM layers to retrieve its data and see it displayed in the plugin
interface. For example, clicking on the river that runs through town gives you this:

Properties | Relations

Key Value
1 name ............................. Coormlands
2 source survey and 1943 1:50K ...
3 waterway river

4 <new tagh...

* You can create new features (point, lines, polygons) as well as edit a feature that you
have identified. For example, using the plugin’s Identify feature tool as before, you can
click on this street:
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\ Swellendam

Looking at its attributes, it doesn’t have a name:

‘ Properties | Relations

Key Value

2 <new tag here>

* Double-click in the <new tag here> field.

* Select a new tag (attribute) from a list. Let’s choose name:
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Properties | Relations

Key Value

1 highway residential
2 name

3 <new tag here>

¢ Double-click in the Value field:

Properties | Relations

Key Value
1 highway residential
2 name Kanonsktraat

3 =new tag here>

You can save your changes to the original source data, too. This makes the changes available
internationally on the OSM server.

* Click the Upload OSM data button:

B

This gives you a dialog, which you can fill in as needed.

* If you have a user account at OSM, you can enter your credentials in the spaces provided
and click the Upload button to save those changes.

Note that the plugin has many other functions: for example, you can also save OSM layers to a
local directory, load data from saved OSM layers, and export OSM data as shapefiles.

OSM’s data comes from, and is maintained by, the efforts of their users. Contributing data
using this plugin allows you to help improve the quality of the OSM data you depend on.

10.2.4 In conclusion

There are many useful plugins available for QGIS. Using the built-in tools for installing and
managing these plugins, you can find new plugins and make optimum use of them.
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10.2.5 What’s next?

Next we’ll look at how to use layers that are hosted on remote servers in real time.
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